понедельник, 26 октября 2009 г.

Устанавливка Adobe AIR на Fedora 10 64-bit.

Проблема с установкой Adobe AIR у меня возникла давно. После нескольких месяцев успешной работы twhirl перестал соединяться с Twitter API. Но так-как у меня успешно работал TwitterFox (новое название Echofon), я эту проблему задвинул в дальний ящик.

Сегодня я решил установить TweetDesk и проблема сразу показала своё "лицо".

1. Перед установкой нужно прочитать этот документ: Install Adobe AIR Linux 1.5 on 64-bit Linux distributions и выполнить рекомендуемые действия.

$ sudo yum install ld-linux.so.2 gtk2-devel.i386
$ sudo yum install libxml2.i386 nss.i386 libXt.so.6
$ sudo yum install gnome-keyring.i386 xterm rpm-libs.i386

2. Для того чтобы Adobe AIR получил доступ к сетевому стеку, придётся установить ещё один пакет. (Без него работать ничего не будет)

$ sudo yum install nss-mdns.i386

3. Скачиваем Adobe AIR http://get.adobe.com/air/ и устанавливаем.

$ chmod +x AdobeAIRInstaller.bin 
$ sudo ./AdobeAIRInstaller.bin 

4. Для установки программ придётся сначала скачать её, а потом установить из терминала.

$ /opt/Adobe\ AIR/Versions/1.0/Adobe\ AIR\ Application\ Installer /path_to/App.air

Если Вам все это не помогло, попробуйте отчистить ELS (AIR's Encrypted Local Storage) и gnome-keyring используя инструкции описаные тут: Troubleshooting AIR's Encrypted Local Storage (ELS) on Linux

UPDATE 12.10.2010:

При установке rpm пакета adobe air версии 2.5.1 в Fedora 14 возникает ошибка:

Adobe AIR could not be installed. Either gnome-keyring or Kwallet must be installed prior to installing Adobe AIR.
error: %pre(adobeair-2.5.1-17730.i386) scriptlet failed, exit status 1
error:   install: %pre scriptlet failed (2), skipping adobeair-2.5.1-17730

Лечится установкой пакета libgnome-keyring.i686:

sudo yum install libgnome-keyring.i686

2 комментария:

  1. Very nicce! [posted by: biaptetty]

    ОтветитьУдалить
  2. Отлично, хоть где-то работает. А я пытаюсь запустить air app под AltLinux-ом. Среда (AIR Runtime) ставится, пытаюсь развернуть air пакет, запускается графический Adobe AIR Application Installer выбираю путь, запускаю и выдает сообщение: "The application could not be installed because the installer file is damaged..." самое главное, что причина то не в файле, а вот в чем не понятно. [posted by: chrm]

    ОтветитьУдалить